Clover Sport Product Support phone lines are currently unavailable.
Incident Report for Clover Sport
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 19:33 CST
Update
We are continuing to work on a fix for this issue.
Posted Nov 13, 2024 - 15:57 CST
Identified
We are aware of the issue and working to have the phones restored with our telecom partner.
You may still use the Support Center on our website for assistance, as well as email.
Posted Nov 13, 2024 - 15:57 CST
This incident affected: Support (Phone Support).